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PLEASE READ: 

This installation guide will guide you through the installation of LytecMD EHR.  If you need assistance installing Lytec 

2010 Practice Management, please refer to the installation guide on the disc or contact technical support.  To reduce 

downtime, please wait to reboot your server until after all registry keys have been applied and edited and User Account 

Control has been turned off.   
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Installing and Configuring SQL Server for LytecMD 

Installing the Database scripts 
1. Locate the installation CD named: LytecMD SQL New Site from the CD Case and insert it into the hard 

drive.  It should Autorun and start the installation.  Click Next. 

 

2. On the “Choose Destination Location” window, select the current default path or select your recommended 

drive letter. (P:\94SQLSetup) by clicking the Browse button.  Once you have picked your destination path, 

click Next. 

 

Once the installation is complete, the window should close.  If not click, Finish. 
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Creating the Database Directory and Setting Permissions 
1. You will need to create the following directories DATA, LOG, PPSYS, and BACKUP inside a folder 

labeled LYTECMD on the P:\ drive for your EMR data.  It is recommended that you use ALL CAPS 

when labeling these folders. 

 

 

 

NOTE: All permissions settings need to be accurate for your network or domain controller on 

the P:\Drive for your EHR Setup.  If you are setup on a domain, you may need to add additional 

permissions to those users as well.  Consult your IT System Administrator for further 

information. 
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2. Adjust the permissions and security to full access rights to the root P:\ drive by right-clicking on the P:\ drive 

from My Computer, select “Share…” and then click on the Advanced Sharing Button. 

 

3. From the Advanced Sharing window, check “Share this folder” and then select the Share Name.  From here 

click the permission button and add USERS, EVERYONE, SYSTEM, and DOMAIN USERS (if you are on 

a domain) then click Ok.  Click Ok again on the Advanced Sharing Window.  You will need to repeat these 

same steps for the  
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4. You will need to add the same permission settings to the P:\ Drive Properties Window by clicking on the 

Security Tab, then click Edit to add the username and/or groups in step 3.  From here apply Full Control to 

all added groups, then click OK, and Close. 
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Create the PP_SQL Instance for EHR 
1. Run PPSQLInstall.bat from the Lytec 2010 Practice Management DVD within the SQL Server x64 location.  

NOTE: If you are installing on a Domain Controller.  You may need to run the SQL Server Installation 

manually.  Please contact customer support for further assistance. 
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2. From here the SQL Server 2005 installer will launch.  Please allow the installer to complete; if the installer 

fails at this point, you may have permission issues and will need to run the SQL manually (Consult technical 

support for further information).  Once the installation is completed the installer will close automatically. 

 

3. Run PPSQLInstallSP3.bat from the Lytec 2010 Practice Management DVD within the SQL Server x64 

location.  This will apply the service pack to your SQL Server Instance (PP_SQL). It should display a DOS 

window with no activity – PLEASE ALLOW THIS TO CLOSE ON ITS OWN. It has completed the service 

pack installation when it disappears. 
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Opening the Ports for the SQL Server Instance 
1. Click Start > Programs>Microsoft SQL Server 2005>Configuration Tools>SQL Server Configuration 

Manager. 

2. Expand SQL Server 2005 Network Configuration and locate Protocols for PP_SQL and right-click on 

the TCP/IP, then select Properties or double-click on the TCP/IP option. 
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3. From the TCP/IP Properties window select the IP Addresses tab.  For IP1, IP2, IP3… and IP All, change 

the TCP Port to 1434 and click OK.  You will receive a request to restart the services. 

NOTE: Your server may have more than three IP* sections within this window; all TCP Ports need to 

have port 1434 in their place. 
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4. You will need to restart the service for SQL Server (PP_SQL), by right-clicking on the SQL Server 

(PP_SQL) option and select Restart under the SQL Server 2005 Services Menu. 

 

5. You will need to open the ports on the server firewall for the Domain Profile, Public Profile and Private 

Profiles within the Server Manager > Configuration Screen.  If you have a third party firewall you will 

need to make sure the ports are open for those as well.  The TCP Ports to add are: 1433, 1434, 50501, 

and 50502. 
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Creating the SQL Database for the EHR 
1. Click Start>Programs>Microsoft SQL Server> Microsoft SQL Server Management Studio.  Be sure to 

select the PP_SQL instance that was created and leave it as Windows Authentication, and then click 

Connect. 

 

2. In SQL Server Management Studio right-Click on the Database main container from the left margin and 

select New Database. 
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3. Within the New Database Window you will need to specify the database name and the location of your 

DATA and LOG folders you created in Step 1 of the “Creating the Database Directory and Setting 

Permissions” section of this document.  Remember that your Database Name needs to be named 

identical and correct CAPS LOCK if necessary.  Once completed click OK and the database will be 

created. 

 

4. Expand the database tree on the left margin and locate “LYTECMD” and verify it has been created.  If 

LYTEDMD is not there, the database was created incorrectly and you will need to repeat Step 3 on this 

section. 
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5. Go to File > Open > File and select the SQL_ppcreate94.sql from P:\94SQLSetup directory that was 

created earlier, and then click Open. 

 

6. Run the Replace All function (CTRL + H) and replace the “*DBNAME*” with “LYTECMD,” then 

click Replace All.  You will receive confirmation of track changes, click Yes.  Repeat the Replace All 

step for “*DRIVE*”with "P,” Then verify your changes. 
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7. This step may be necessary when creating the script on a domain with strict password.  With the 

“sql_ppcreate94” script if you scroll down, you will see the PM$IADMIN password.  It is suggested you 

change the password to “PM$IADM1N” for a stronger password before executing the script. 

 

8. Make sure your cursor is at the top of the script, and then click Execute.  If the script runs successfully 

you will receive a confirmation in the Message status area. 
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9. Go to File > Open > File and select the script named: SQL_Set_Blank94.sql and Execute (there is no 

need for a replace all on this script). 

10. Go to File > Open > File and select the script named: SQL_Add_MRZLIndex.sql and run a Replace 

All function on the “DBNAME” with “LYTECMD” then Execute the script. 
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Setting up the ODBC Connection for 32 Bit and 64 Bit 
 

64-Bit Setup 

1. Select Start>Settings>Control Panel>Administrative Tools>ODBC Data Source, then click on System 

DSN tab, and then click Add. 

 

2. From the “Create New Data Source” window, select the SQL Server option, and then click Finish. 
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3. Input the Database Name “LYTECMD” or the one you used for the EHR database.  Remember to take 

in consideration the case sensitivity, and then click Next. 

 

 

4. On the “Create a New Data Source to SQL Server” be sure to have SQL Server authentication selected, 

and then click the Client Configuration button. 

5. Within the “Add Network Library Configuration” window, the server alias will need to be the database 

name and the server name followed by the SQL instance (servername/PP_SQL).  Be sure TCP/IP 

network library is selected and uncheck dynamically determine port; change the port to 1434, and then 

click OK. 
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6. For the login account, you will use the login that was setup when you ran the pp_sqlcreate scripts back 

on step 7 of the section “Creating the SQL Database for the EHR.”  Once the password has been entered 

click Next. 

 

7. If you are able to continue to the next screen, your password has been accepted.  If the password is 

incorrect, you will receive an error message like this:  This means the password is incorrect or a firewall 

may be blocking the SQL Port – 1434. 
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8. If you are able to successfully continue past the login screen, you can click Next, Next again, and then 

Finish as the default options for these screens are the standard.  Last you can test the data source 

connectivity and click OK to save your data source.  You have now setup the 64-bit ODBC. 

 

 

32-Bit Setup 

 

1. To setup the 32-bit ODBC, you will need to browse to the following directory or enter this path in the 

Run Command box by going to Start > Run: 

 

2. This will take you to the “ODBC Data Source Administrator” for the 32-bit setup, which will look very 

similar to the setup that was done on the 64-Bit ODBC. 

3. You will repeat the same steps 1-8 from the “64-Bit Setup” except this time you will have to scroll down 

in the “Create New Data Source” window and locate the SQL Server data source. 
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Disabling User Access Control (UAC) on Server 2008 – [Reboot Required] 
In order for the installation of the EHR to go smoothly and for the client to run on the server, UAC must be 

turned off.  Once it is turned off, you will need to reboot the server for the changes to take effect.  Below are the 

steps to turn off UAC on Server 2008 Standard. 

1. Go to Start > Control Panel > User Accounts and click on the link “Turn User Account Control on or 

off.” 
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2. From within the window be sure to uncheck UAC and/or turn it to the OFF or Do not Show option, and 

then click OK.  You may be prompted to restart the machine for the setting to take effect, but wait to 

reboot after all registries have been added. 
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Shut off SMB2 on Server 2008 – [Reboot Required] 
 

There are compatibility Issues with SMB2 Protocol and McKesson EMRs 

With Windows 2008 and Windows Vista, Microsoft introduced a newer, faster communication method known 

as SMB2.  Older versions of Windows use SMB1. 

Older and mixed environments (for example, Windows 2003 server and Windows Vista client) will 

communicate using SMB1.  Only direct communication between Vista and newer operating systems (Windows 

2008, Windows 7, etc.) will use SMB2. 

Problem 

McKesson has identified a compatibility problem with its EMR products (Practice Partner, Lytec MD and 

Medisoft Clinical) and SMB2.  This incompatibility can lead to erratic errors, file locking and/or corrupted 

database tables.  The incompatibility centers around the inability to disable opportunistic locking (oplocks) on 

the SMB2 protocol.  For this reason, SMB2 must be disabled on Windows 2008 and Windows Vista computers 

that will be running a McKesson EMR. 

To prevent future compatibility problems due to the inability to disable oplocks, McKesson recommends 

disabling the SMB2 protocol on all Windows Server 2008 servers being used by a McKesson EMR. 

Resolution 

To disable SMB2 on Windows 2008: 

1. Run REGEDIT from the Start > Run 

2. Navigate to the key. 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters. 

3. Click Edit>New>DWORD (32-bit) Value. 

4. Enter SMB2 as the new value name. 

5. Exit REGEDIT. 

6. Restart Windows 2008. 
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Add the Mandatory RegKeys to the 64-Bit Server - [Reboot Required] 
In order for the EHR and Lytec 2010 to be recognized on the server as an installed application within a 64-bit 

environment, you will need to download and apply these registry keys: 

1. Download two registry keys by clicking the links below, and Save them to your Desktop: 

LytecMD_RegKey1 & LytecMD_RegKey2 

2. Import the keys by double-clicking on each key, then click Yes to add them to the machine.  You will 

receive confirmation when the keys have been added. 

 

 

3. It may be a good idea to store these keys somewhere on your computer in case you need to reference 

them again later. Saved on 940SQLSetup folder 

4. The last key is to reduce data corruption and locking.  Browse to your LytecMD 9.4 installation disc, 

and locate the file under \Ppartprw\pic\ntpmsi.reg. 

5. Double click on ntpmsi.reg file to apply it to the registry. Then reboot your server. 

  

http://lytec.com/download/LytecMD64BITREGFIX/LytecMD64Bit-Part1.reg
http://lytec.com/download/LytecMD64BITREGFIX/LytecMD64Bit-Part2.reg
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Installing Patient Records 

Create License Folder and Install Server files 
1. Create two folders labeled ppart and License on the root of the P:\ drive. Make sure there is a copy of 

the LytecMD license file (pplic.txt) located within P:\License.  If you are having issues retrieving your 

license file from the McKesson Practice Partner Support Website, please contact Technical Support. 

 

2. Insert the LytecMD Core install Disc, the Autorun should automatically start the installation.   

If not you can manually open the Ppartprw folder and run Setup.exe from the disc contents in 

Windows Explorer. It will request to install .net1.1 SP1 which is located at root setup.exe  

3. Click Next to start the installation of Patient Records. 

4. Accept the License Agreement 

  



27 

 

5. Enter the path of your ppart directory; it will default as P:\ppart.  If you used another drive letter like”X” 

then browse for that drive letter and ppart location.  It is STRONGLY recommended you use “P” as 

your drive letter.  Drives, C, D, and E are prohibited. 

 

6. The installer will next ask if you have a license file (pplic.txt).  Click Yes to continue. 
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7. Once you have the license directory located P:\License, then click Next. 
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8. You will then be asked to create a logon for LytecMD, be sure to follow the required criteria, and then 

click Next.  It will then ask you to confirm your password, and then click Next again. 
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9. For the Image Levels window, the default values are recommended.  Click Next to continue. 

 

10. Click No, on Automatically Generate Demographic ID numbers.  Lytec 2010 will handle the 

Demographic ID numbers. 
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11. Select the desired Growth Chart Range, and then click Next. 

 

12. Please wait as the installation installs and updates the necessary files. 
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13. Click Yes, on installing the E&M Coding for Progress Notes. 

 

14. Click Yes or No, when adding the EM labels to the note.  Please wait as it updates the files. 

 

15. Select Windows Networks, and then click Next. 

16. For the SQL Server Instance Information, you will need the Database Name and the Connection 

password, in this case its LYTECMD and PM$IADM1N and then click Next. 
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17. If your system does not have the .Net 2.0 patch it will apply it on the next screen.  Click Ok to apply the 

patch to .Net 2.0 and the Hotfix to 1.1 if prompted. 

18. Click Yes or No to configure the port numbers and extension for LytecMD.  The default ports used for 

the application are 50501 and 50502. 

 

19. Click No, on the prompt to Activate the LytecMD clearinghouse.  All Clearinghouse activation will be 

handled by the EDI Services. 

20. Click Ok, on the DemSch and BillCode messages to configure manually.  Please refer to the 

“PPConnect_DemSch_Billing_UserGuide.pdf” document on the CD for how to configure the Cross-

reference Files. 

21. Click Yes or No on the ReadMe prompt. 

22. Click Ok, to complete the installation. 

  



34 

 

Create the Patient Records Database for SQL Server 
This step will copy the database structure from the ppart directory to run on SQL Server. 

1. Open the p:\ppart directory and locate the file: ppmon.fl.  You will then need to right-click on the file 

and rename to ppmon.fl.old. 

2. Open the DOS command prompt by going Start > Run and type in “cmd” and hit Run to open the 

command prompt window. 

3. Browse the P:\ppart directory in the DOS Command Prompt Window, by typing in P: [Enter], then 

cd\ppart.  This should take you to the prompt: P:\ppart. 
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4. Type in pppwd sqlsvr::PHTECH/PM$IADM1N@LYTECMD -1.  There is a space between 

LYTECMD and the (-1). Then hit [Enter] to run the command.  You should receive a Successful 

message as it creates a new ppmon.fl file with the password you specified in the command. 

 

5. You can leave the DOS Command Prompt window open or minimized, as you will need it in an 

upcoming step. 

6. From Windows Explorer, browse to P:\94SQLSetup and locate the file ppcpy94.lst.  Right click on the 

file and select Copy.  Browse to the P:\ppart and right-click in the folder and paste the ppcpy94.lst file 

within the ppart directory.  You should now see the ppcpy94.lst file within the ppart contents. 

7. Right Click on the P:\ppart\ppcpy94.lst file and select Open.  Select the option “Select the program from 

a list of installed programs,” and then click Ok. 

 

8. Highlight Notepad and click Ok.  The file will open in a notepad format to be further edited. 
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9. Replace All (Ctrl+H) the *DBNAME* with LYTECMD and replace *Password* with PM$IADM1N 

and Then go to File > Save. 

 

10. Open or Maximize the DOS Prompt window from Step 4.  From the P:\ppart directory type in the 

following command: ppcpy @ppcpy94.lst (there is a space between ppcpy and @ symbol) and then hit 

[Enter].  If you receive an error -312, then consult Technical Support for further assistance. 

 

11. Once the copying process is completed, the DOS window will revert back to the prompt of P:\ppart.  

You can now close the DOS window or type Exit.  This process can take up to one hour to copy 

depending on the hardware. 
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Installing the LytecMD Client 
This step will install the LytecMD client, in order to launch the application.  If you are installing the client on a 

workstation, then remember to install the 32Bit ODBC and map a network drive to the P Drive share. 

1. Browse to P:\ppart\install\setup.exe 

2. The installer will launch, and then click Next to continue. 

 

3. Install to the default C:\PRWIN location or change it to another drive letter if desired, and then click 

Next. 

4. The installation will install and update the files, please wait. 

5. Click Yes or No to “Is this client being installed on a Windows Terminal Server, Citrix Winframe, or 

Metaframe server” depending on your network setup. 
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6. Click Next, on the Folder Selection window.  The defaults are standard, but the folder selection can be 

changed. 

7. Click Ok, on the setup complete. 

8. You will have a LytecMD Client icon appear.  You can add this to the Desktop by right-clicking on the 

icon and selecting Send To > Desktop (create shortcut). 

9. Launch the client by double-clicking on the icon:  

10. Allow the program to update files upon launch.  This process can take up to 10 minutes. 

 

11. Verify the PMSI Application and Data Server are started in the Windows Services Menu (services.msc) 


